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Druki pomocnicze do ćwiczeń G1/G2 
(do zwrotu po zajęciach) 
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1. Uruchomienie programu ER Mapper 6.0. 

Należy dwukrotnie kliknąć na ikonie na pulpicie Windows. 

2. Wyświetlenie paska narzędzi z kreatorami (Wizards). 
W menu głównym wybrać polecenie Toolbars →Wizards.

3. Otwieranie plików danych geofizycznych: 
Każdy rodzaj danych można otworzyć za pomocą kreatorów.  

a. Zdjęcia 
• Kliknąć przycisk (Image Display and Mosaic Wizard)

• W oknie kreatora nacisnąć przycisk i wybrać plik ze zdjęciem. 

• Zaznaczyć pole Manualny set display metod i nacisnąć przycisk Next.

• Wybrać sposób wyświetlania obrazu: Grayscale lub Red Greek Blue, zaznaczyć pole 
Manualny select display metod properties i nacisnąć przycisk Next.

• Wybrać pasma spektralne, które mają być wyświetlane i kliknąć Next, potem Finish.

b. Landsat TM 
• Kliknąć przycisk (Landsat TM Wizard)

• W oknie kreatora nacisnąć przycisk i wybrać plik ze zdjęciem oraz rodzaj podglądu z listy 
Type.

• Nacisnąć przycisk Finish.
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c. Spot 
• Kliknąć przycisk (Common Geophysical Images Wizard). 

• W oknie kreatora nacisnąć przycisk i wybrać plik ze zdjęciem. 

• Zaznaczyć pole Density sliced (Pseudocolor). Nacisnąć pole Next. 

• Wybrać pasmo spektralne do wyświetlania oraz tabelę LUT (kolor). 

• Zaznaczyć opcję Apply smoothing… I nacisnąć przycisk Finish. 

4. Powiększanie, zmniejszanie i przesuwanie obrazka. 
– Powiększenie klikniętego obszaru. 
– Powiększenie zaznaczonego obszaru. 

Najazd i płynne oddalenie przy wciśniętym lewym przycisku myszki. 
– Przesunięcie zdjęcia. 
– Powrót do trybu zaznaczania. 

Powrót do pełnego zdjęcia z menu głównego: View → Quick Zoom → Zoom to All Datasets.

5. Powielanie zdjęcia. 

Kliknąć przycisk (Copy Window). Często nowe okno dokładnie pokrywa położenie 
poprzedniego okna. 

6. Podmiana zdjęcia. 
W oknie algorytmu (pkt. 8) nacisnąć przycisk (Load dataset) I wybrać żądany plik. 

7. Obrazowanie 3D – Mapa wysokości. 
• Nacisnąć przycisk (3D Algorithm Wizard). 

• Zaznaczyć opcję wyświetlania: Pseudocolor lub RGB (321) I kliknąć przycisk NEXT.
• Nacisnąć przycisk z prawej strony pola Raster dataset i wybrać plik, który będzie 

przedstawiany. 

• Z listy Color Table (w przypadku opcji pseudokolorowania) wybrać tabelę LUT. 
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• Nacisnąć przycisk z prawej strony pola Height dataset I wybrać plik, który zawiera dane o 
wysokościach. Nacisnąć przycisk Finish. 

8. Algorytmy. 
a. Otwieranie algorytmu z pliku. 

• Nacisnąć przycisk w głównym oknie programu i wybrać algorytm (*.alg).  
• Aby obejrzeć definicję algorytmu należy otworzyć okno algorytmu (pkt 8.b). 

b. Wyświetlanie okna algorytmu. 
Nacisnąć przycisk (Edit algorithm) z okna głównego aplikacji. 

c. Automatyczna poprawa kontrastu. 
Nacisnąć przycisk (99% Kontrast Enhancement) z okna głównego aplikacji lub okna 

algorytmu. 

d. Zmiana kolorystyki zdjęcia. 
W oknie algorytmu, na karcie Surface, nacisnąć przycisk Colortable i wybrać predefiniowaną

tabelę LUT. 

e. Zmiana pasma spektralnego. 
W oknie algorytmu, na karcie Layer, rozwinąć listę pasm i wybrać żądane pasmo. 
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f. Histogram obrazu. 
• W oknie algorytmu nacisnąć ikonę (Edit transform limits). 

• Po otwarciu okna histogramu (pkt 8.f) wybrać jedną z dziewięciu predefiniowanych 
transformacji lub przeciągać, dodawać i odejmować uchwyty linii definiującej 
transformację. (przez klikanie i przeciąganie w dowolnym punkcie linii transformaty) 

g. Filtracja lokalna. 
• W oknie algorytmu nacisnąć ikonę (Edit filter). 

• W oknie filtru, nacisnąć przycisk File i wybrać polecenie Load.

• Wybrać jeden z dostępnych filtrów. 

• Aby usunąć filtr należy nacisnąć przycisk Edit i wybrać polecenie Delete this filter.

h. Operacje punktowe. 
• W oknie algorytmu nacisnąć ikonę (Edit formula). 

• W oknie edytora filtru z menu Ratios wybrać odpowiednią formułę filtru lub ilość zmiennych 
formuły. 
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• W górnym białym polu wpisać nową formułę i potwierdzić ją naciśnięciem przycisku Apply 
changes.

• W środkowej części okna ustalić, jakie pasma odpowiadają poszczególnym zmiennym. 

• Na zakończenie poprawić kontrast (pkt.8.c). 

• Aby usunąć operację punktową w oknie edytora filtru należy kliknąć przycisk Edit i wybrać
polecenie Default.

i. Dodawanie nowych warstw do obrazu. 

• W oknie algorytmu, przycisnąć przycisk Edit wybrać polecenie Add raster laser.

• Wybrać rodzaj warstwy. 

j. Zapisywanie algorytmów. 

• W oknie głównym programu wybrać polecenie File Save As.

• Wybrać katalog docelowy i wpisać nazwę pliku. 

• Z listy Files of Type wybrać opcję ER Mapper Virtual Dataset (.ers) i nacisnąć OK. 

• Na pytanie Delete output transforms for virtual dataset odpowiedzieć klikająć przycisk YES. 

9. Sprawdzanie współrzędnych piksela. 

• Z menu głównego programu należy wybrać polecenie View → Cell coordinate.
• Przycisnąć ikonę i kliknąć wybrany piksel w obrazie. 

10. Profil spektralny piksela. 

• Z menu głównego programu należy wybrać polecenie View → Cell values profile.

• Wybrać w dowolnej konfiguracji opcje działania: Signature (profil), Neighbors (sąsiedztwo) 
lub Values (wartości). 

• Przycisnąć ikonę i kliknąć wybrany piksel w obrazie. 
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• Wybierając pole Average w oknie profilu, i wybierając kolor można zaznaczać grupy pikseli I 
wyświetlać ich średni profil (uśredniony po wszystkich pikselach na drodze myszki). 

11. Wyznaczanie wskaźnika wegetacji. 
Dla otwartego zdjęcia wielospektralnego z Landsata: 

• Otworzyć okno algorytmu (pkt.8.b). 

• Otworzyć okno operacji punktowych (pkt.8.h). 
• W oknie edytora formuł, z menu wybrać polecenie Ratios → Landsat TM NDVI (pkt.8.h). 

Nacisnąć przycisk Close. 

• Poprawić kontrast przez naciśnięcie przycisku (pkt.8.c). 

Gdy zdjęcie nie jest otwarte: 
• Nacisnąć przycisk (pkt.3.b) 

• W oknie kreatora nacisnąć przycisk i wybrać plik ze zdjęciem. 

• Z listy Type wybrać pozycję Vegetation NDVI.

• Nacisnąć przycisk Finish.

• Dla celów lepszej wizualizacji można zmienić tablicę LUT na Greek (pkt.8.d) 

12. Klasyfikacja 
a. Klasyfikacja bez nadzoru 

• W oknie głównym programu wybrać polecenie Process → Classification → ISOCLASS 
Unsupervised Classification.

• W oknie Unsupervised Classification nacisnąć przycisk po prawej stronie pola Input 
Dataset i wybrać plik ze zdjęciem, które ma być poddane klasyfikacji. 

• Pole Bands to use służy do wyboru pasm spektralnych, które mają być brane pod uwagę
podczas klasyfikacji. Domyślnie wybrana jest wartość All (wszystkie). 

• Nacisnąć przycisk po prawej stronie pola Output Dataset, wybrać folder docelowy i 
wpisać nazwę pliku wynikowego. 

• W sekcji Options ustala się opcje działania algorytmu. 

Maximum iterations – maksymalna liczba iteracji. (zalecane ok. 100) 

Desired percent unchanged – jaka część pikseli nie zmienia swojej przynależności do klasy 
podczas końcowej iteracji. (zalecane 98%) 

Sampling row/kolumn interval – co który wiersz i kolumna brane są pod uwagę w czasie 
klasyfikacji. (domyślnie 1) 



Wprowadzenie do cyfrowego przetwarzania zdjęć satelitarnych 

Rafał Kasztelanic Strona 8 

Maximum numer of classes – maksymalna tworzona liczba klas. (nie powinna znacząco 
odbiegać od liczby różnych rodzajów terenów w przetwarzanym zdjęciu) 

Minimum members in a class – warunek odrzucenia klasy jeśli składa się z zamałej liczby 
pikseli. 

Pozostałe parametry jeśli nie znamy charakterystyki zdjęcia, zwykle pozostawia się bez 
zmiany 

• Nacisnąć przycisk OK. 

• Po ukazaniu się komunikatu o zakończeniu klasyfikacji należy przycisnąć przycisk OK, 
następnie kliknąć Close w oknie Processing Status oraz kliknąć przycisk Cancel w oknie 
Unsupervised Calssification.

b. Klasyfikacja nadzorowana. 
Klasyfikacje nadzorowaną przeprowadza się w kilku kolejnych etapach. 

i. Zaznaczanie regionów treningowych. 

• Mając otwarte okno ze zdjęciem, wybrać z menu w głównego programu polecenie Edit →
Edit/Create Regions.

• W oknie New Map Composition zaznaczyć opcję Raster Region.

• Sprawdzić czy w polu Load from File zaznaczone jest właściwe zdjęcie. Jeśli nie, to należy
przycisnąć przycisk i wybrać odpowiednie zdjęcie. Nacisnąć przycisk OK. 

• Wybrać i powiększyć w oknie obrazka region, który ma być zaznaczony. 

• W oknie Tools kliknąć przycisk (Poligon). Kliknąć w oknie obrazu pierwszy punkt 
wielokąta definiującego region, kliknąć drugi punkt, …, dwukliknąć ostatni punkt 
wielokąta. Wielokąt zostanie automatycznie zamknięty. 

• Zaznaczyć w razie konieczności dany wielokąt. Nacisnąć przycisk (Dispaly/Edit Object 
Attributes). W dużym polu na dole okna Map Composition Attribute nalęzy wpisać nazwę
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regionu (litery tylko z alfabetu angielskiego oraz nie używanie takich znaków jak: kropka, 
przecinek, spacja). 

• Nacisnąć przycisk Apply. Zamknąć okno naciskając Close.

• Nacisnąć przycisk (Select/Edit Points Mode) i dwukliknąć dowolną linię wielokąta. 

• Nacisnąć przycisk Set Color i wybrać kolor jakim będzie reprezentowany dany region 
(kolor ten będzie można zmienić później, nawet po klasyfikacji pkt.12.g). Nacisnąć 
przycisk Close.

• Nacisnąć przycisk (Save File), potwierdzić zastąpienie pliku (Overwrite) i sprawdzić,
czy w oknie Message Window są pokazane wszystkie zaznaczone regiony. Zamknąć okno 
naciskając przycisk Close. 

• Powtórzyć czynności od zaznaczania obszarów dla wszystkich regionów treningowych. 

• Zamknąć okno Tools kliknięciem przycisku Close.

UWAGA: Zaznaczenie regionów powoduje utworzenie nowej warstwy wektorowej o 
domyślnej nazwie Region LayerRegion Layer (Outline), widocznej w oknie algorytmu. 

ii. Usuwanie regionów treningowych. 

• Jeśli nie jest widoczne okno Tools, to należy je wyświetlić wybierająć z menu głównego 
programu polecenie Edit → Edit/Create Regions (pkt.12.b.i). 

• Nacisnąć przycisk (Select/Edit Points Mode) i zaznaczyć dowolny region kliknięciem. 

• Nacisnąć przycisk (Delete Object). 

• Nacisnąć przycisk (Refresh). 

iii. Łączenie regionów treningowych. 

• Dwa rozłączne obszary treningowe traktowane są jak jeden gdy mają tę samą nazwę.

iv. Obliczanie statystyki. 

• W oknie głównym programu wybrać polecenie Process → Calculate Statistics.

• W oknie dialogowym Calculate Statistics sprawdzić, czy w polu Dataset jest wyświetlana 
poprawna nazwa pliku. Jeśli nie, to należy nacisnąć przycisk , i wybrać odpowiedni plik. 

• Liczba znajdująca się w polu Subsampling inteval określa, co który piksel brany jest pod 
uwagę przy liczeniu statystyki. Dla większości przypadków wystarczającym próbkowaniem 
jest branie co 4 piksela (wartość 4). 

• Nacisnąć przycisk OK. Jeśli statystyki były już liczone wcześniej to można wymusić
ponowne ich obliczenie przez zaznaczenie opcji Force recalculate status.

• W polu statusu można obserwować stopień zaawansowania obliczeń.

• Po zakończeniu obliczeń, kliknąć przycisk OK. w oknie z informacją o zakończeniu 
obliczeń, potem przycisk Close w oknie statusu oraz przycisk Cancel (nie klikać OK) w 
oknie Calculate Statistics.
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v. Wykonanie klasyfikacji nadzorowanej. 

• W oknie głównym programu wybrać polecenie Process → Classification → Supervised 
Classification.

• W oknie Supervised Classification, nacisnąć przycisk , znajdujący się po prawej stronie 
pola Input Dataset i wybrać plik, który ma być klasyfikowany. 

• Wybrać pasma spektralne mające być brane pod uwagę w czasie klasyfikacji naciskając
przycisk w polu Input Bands.

• Naciskając przycisk po prawej stronie pola Output Dataset wybrać nazwę pliku 
wynikowego. 

• Wybrać rodzaj stosowanego algorytmu klasyfikacji naciskając przysk po prawej stronie 
etykiety Classification Type.

• Jeśli klasyfikacja ma być wykonana z użyciem różnych prawdopodobieństw występowania 
terenów, to należy nacisnąć przycisk Setup…, i dla każdej klasy podać odpowiednią
wartość prawdopodobieństwa (po zsumowaniu, prawdopodobieństwa nie mogą dawać
wartości większej niż 1). Zamknąć okno Setup.

• Nacisnąć przycisk OK. 

c. Wyświetlanie wyników klasyfikacji. 

• Nacinąć przycisk (New), by utworzyć nowe okno. 

• Otworzyć okno algorytmu (pkt.8.b). 

• Na karcie Laser, wcisnąć przycisk (Load dataset) i wybrać plik zawierający wynik 
klasyfikacji. 

• Kliknąć nazwę warstwy Pseudo Laser prawym klawiszem myszki i wybrać opcję Lass 
Dispaly (pkt.8.d). 

d. Wyświetlanie statystyki. 

• Wybrać z menu głównego programu polecenie View → Statistics → Show Statistics.

• W oknie Statistics Report, sprawdzić czy w polu Input Dataset jest podana prawidłowa 
nazwa pliku wejściowego (z obliczonymi wcześniej statystykami). Jeśli nie, to należy
nacisnąć przycisk , i wybrać odpowiedni plik. 

• Wybrać regiony lub klasy do wyświetlenia w polu Region/Class, wybrać odpowiednie pasma 
obrazu w polu Bands List. Pola Minimum Fidel width oraz Number of decimal places 
zawierają parametry formatowania liczb, odpowiednio: szerokość i liczbę miejsc po 
przecinku. Nacisnąć przycisk Dispaly.
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• Aby wydrukować lub zapisać do pliku dane statystyczne należy nacisnąć przycisk Print…,
następnie w oknie dialogowym Print Dataset Statistics wybrać odpowiednią opcję: Printer 
lub File. W przypadku opcji File, należy nacisnąć przycisk i podać nazwę pliku 
docelowego. 

e. Zmiana kolorów w obrazie po klasyfikacji. 

• Wybrać z menu głównego programu polecenie Edit → Edit Class/Region Color and Name.

• W oknie Edit Class/Region Details nacisnąć przycisk po prawej stronie pola Dataset i 
wybrać plik, zawierający zdefiniowane regiony/klasy. 

• W celu automatycznego przyporządkowania kolorów należy wybrać przycisk Auto-gen 
colors…, w oknie Auto-generate colors zaznaczyć pole Full saturationi kliknąć przycisk 
Auto-gen. Zamknąć okno naciskająć przycisk Close.

• W przypadku ustawiania/zmiany koloru należy nacisnąć przycisk Set color po prawej stronie 
odpowiedniej klasy i wybrać dla niej kolor. 

• Nacisnąć przycisk Save, aby zapisać zmiany w pliku.  

• Zamknąć okno przez naciśnięcie przycisku Close.

• Nacisnąć przycisk (Refresh), aby odświeżyć obraz. 

f. Obliczanie powierzchni poklasyfikowanych terenów. 
• Dane te są dostępne po obliczeniu statystyki (pkt.12.b.iv) w oknie Display Dataset Statistics 

(pkt.12.d). 
 


